Puppet Class: mediawiki::packages

Defined in:
modules/mediawiki/manifests/packages.pp

Overview

Class mediawiki::packages

Packages needed for mediawiki



4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
# File 'modules/mediawiki/manifests/packages.pp', line 4

class mediawiki::packages {
    include ::imagemagick::install

    # vips is needed for (rare) non-Thumbor scaling of TIFF/PNG uploads (T199938)
    require_package('python-imaging', 'tidy', 'libvips-tools')

    # PDF and DjVu
    require_package('ghostscript', 'djvulibre-bin', 'librsvg2-bin', 'libtiff-tools', 'poppler-utils')

    # ploticus for EasyTimeline extension (T237304)
    require_package('ploticus')

    # Score
    if os_version('debian == stretch') {
        apt::package_from_component { 'lilypond':
            component => 'component/lilypond',
            packages  => ['lilypond', 'lilypond-data']
        }
    } else {
        require_package('lilypond')
    }
    require_package('timidity', 'freepats', 'fluidsynth', 'fluid-soundfont-gs', 'fluid-soundfont-gm')

    require_package('firejail')

    # SecurePoll is incompatible with gpg2 (T209802)
    require_package('gnupg1')
}