Puppet Class: openstack::keystone::service::queens::stretch

Defined in:
modules/openstack/manifests/keystone/service/queens/stretch.pp

Overview



1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
# File 'modules/openstack/manifests/keystone/service/queens/stretch.pp', line 1

class openstack::keystone::service::queens::stretch(
) {
    require ::openstack::serverpackages::queens::stretch

    # pull in python-ldap version 3+ from the buster repo.
    #  older versions don't handle unicode properly.
    #  T229227
    apt::repository { 'stretch-wikimedia-component-python-ldap-bpo':
        uri        => 'http://apt.wikimedia.org/wikimedia',
        dist       => stretch-wikimedia,
        components => 'component/python-ldap-bpo',
        before     => Package['keystone'],
        notify     => Exec['apt_update_python_ldap'],
    }
    exec {'apt_update_python_ldap':
        command     => '/usr/bin/apt-get update',
        refreshonly => true,
    }

    $packages = [
        'keystone',
        'alembic',
        'ldapvi',
        'python3-ldap3',
        'ruby-ldap',
        'python3-mwclient',
        'libapache2-mod-wsgi-py3',
    ]

    package { $packages:
        ensure  => 'present',
    }
}