Puppet Class: openstack::nova::compute::service::queens::stretch

Defined in:
modules/openstack/manifests/nova/compute/service/queens/stretch.pp

Overview



1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
# File 'modules/openstack/manifests/nova/compute/service/queens/stretch.pp', line 1

class openstack::nova::compute::service::queens::stretch() {
    require openstack::serverpackages::queens::stretch

    # make sure we don't have libssl1.0.0 installed. We don't need it in
    # cloudvirt servers running stretch, and it can cause conflicts resolving
    # dependencies
    package { 'libssl1.0.0':
        ensure => 'absent',
    }

    # the libvirt-daemon-system install may trigger an update-initramfs run.
    # under some circumstances, the busybox package may not be installed, thus
    # failing the complete stack installation, because initramfs requires it,
    # but is declared as Recommends and not Depends
    package { 'busybox':
        ensure => 'present',
    }

    $packages = [
        'libvirt-daemon-system',
        'libvirt-clients',
        'python3-libvirt',
        'qemu-system',
        'spice-html5',
        'websockify',
        'dnsmasq-base',
        'qemu-utils',
        'libguestfs-tools',
        'nova-compute',
        'nova-compute-kvm',
    ]

    package { $packages:
        ensure  => 'present',
        require => Package['busybox'],
        before  => Package['virt-top'],
    }

    # install this later, once the right version of libvirt0 is already present
    package { 'virt-top':
        ensure => 'present',
    }

    service { 'libvirtd':
        ensure  => 'running',
        enable  => true,
        require => Package[libvirt-daemon-system],
    }
}