Puppet Class: profile::toolforge::apt_pinning

Defined in:
modules/profile/manifests/toolforge/apt_pinning.pp

Overview



3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
# File 'modules/profile/manifests/toolforge/apt_pinning.pp', line 3

class profile::toolforge::apt_pinning {
    #
    # linux kernel
    #
    # virtual meta-package, they usually have 3 levels of indirection:
    # linux-meta -> linux-meta-4.9 -> linux-image-4.9-xx
    $linux_meta_pkg =  'linux-image-amd64'
    case debian::codename() {
        'bullseye': {
            $linux_meta_pkg_version   = 'version 5.10.46-4'
            # actual kernel package. Pinning only this is not enough, given that the meta-package
            # could be upgraded pointing to another version and then you would have a pending reboot
            $linux_pkg                = 'linux-image-5.10.0-8-amd64'
            $linux_pkg_version        = 'version 5.10.46-4'
            $libpam_pkg_version       = 'version 1.4.0-9'
            $libpam_ldapd_pkg_version = 'version 0.9.11-1'
            $ldap_utils_pkg_version   = 'version 2.4.57+dfsg-3'
            $libnss3_pkg_version      = 'version 2:3.61-1'
            $libnfsidmap2_pkg_version = 'version 0.25-6'
            $ldapvi_pkg_version       = 'version 1.7-10*'
            $sudo_ldap_pkg_version    = 'version 1.9.5p2-3'
            $nscd_pkg_version         = 'version 2.31-13'
            $python_ldap_pkg_version  = 'version 3.2.0-4'
            $libnss_db_pkg_version    = 'version 2.2.3pre1-6'
            $nfs_common_pkg_version   = 'version 1:1.3.4-6'
            $sssd_pkg_version         = 'version 2.4.1-2'
        }

        'buster': {
            $linux_meta_pkg_version   = 'version 4.19+105+deb10u1'
            # actual kernel package. Pinning only this is not enough, given that the meta-package
            # could be upgraded pointing to another version and then you would have a pending reboot
            $linux_pkg                = 'linux-image-4.19.0-5-amd64'
            $linux_pkg_version        = 'version 4.19.37-5+deb10u2'
            $libpam_pkg_version       = 'version 1.3.1-5'
            $libpam_ldapd_pkg_version = 'version 0.9.10-2'
            $ldap_utils_pkg_version   = 'version 2.4.47+dfsg-3+deb10u1'
            $libnss3_pkg_version      = 'version 2:3.42.1-1+deb10u1'
            $libnfsidmap2_pkg_version = 'version 0.25-5.1'
            $ldapvi_pkg_version       = 'version 1.7-10*'
            $sudo_ldap_pkg_version    = 'version 1.8.27-1+deb10u3'
            $nscd_pkg_version         = 'version 2.28-10'
            $python_ldap_pkg_version  = 'version 3.1.0-2'
            $libnss_db_pkg_version    = 'version 2.2.3pre1-6+b6'
            $nfs_common_pkg_version   = 'version 1:1.3.4-2.5'
            $sssd_pkg_version         = 'version 1.16.3-3.2'
        }
        'stretch': {
            $linux_meta_pkg_version   = 'version 4.9+80+deb9u3'
            $linux_pkg                = 'linux-image-4.9.0-5-amd64'
            $linux_pkg_version        = 'version 4.9.65-3+deb9u2'
            $libpam_pkg_version       = 'version 1.1.8-3.6'
            $libpam_ldapd_pkg_version = 'version 0.9.7-2'
            $ldap_utils_pkg_version   = 'version 2.4.44+dfsg-5+deb9u1'
            $libnss3_pkg_version      = 'version 2:3.26.2-1.1+deb9u2'
            $libnss_db_pkg_version    = 'version 2.2.3pre1-6+b6'
            $libnfsidmap2_pkg_version = 'version 0.25-5.1'
            $ldapvi_pkg_version       = 'version 1.7-10*'
            $sudo_ldap_pkg_version    = 'version 1.8.19p1-2.1+deb9u3'
            $nscd_pkg_version         = 'version 2.24-11+deb9u1'
            $nfs_common_pkg_version   = 'version 1:1.3.4-2.1'
            $python_ldap_pkg_version  = 'version 2.4.28-0.1'
        }
        default: {
            fail("${debian::codename()}: not supported")
        }
    }
    apt::pin { 'toolforge-linux-meta-pinning':
        package  => $linux_meta_pkg,
        pin      => $linux_meta_pkg_version,
        priority => 1001,
    }
    apt::pin { 'toolforge-linux-pinning':
        package  => $linux_pkg,
        pin      => $linux_pkg_version,
        priority => 1001,
    }

    apt::pin { 'toolforge-libpam-pinning':
        package  => 'libpam-runtime libpam-modules* libpam0g',
        pin      => $libpam_pkg_version,
        priority => 1001,
    }
    apt::pin { 'toolforge-libpam-ldapd-pinning':
        package  => 'libpam-ldapd nslcd* libnss-ldapd',
        pin      => $libpam_ldapd_pkg_version,
        priority => 1001,
    }
    apt::pin { 'toolforge-ldapvi-pinning':
        package  => 'ldapvi',
        pin      => $ldapvi_pkg_version,
        priority => 1001,
    }
    apt::pin { 'toolforge-sudo-ldap-pinning':
        package  => 'sudo-ldap',
        pin      => $sudo_ldap_pkg_version,
        priority => 1001,
    }
    apt::pin { 'toolforge-nscd-pinning':
        package  => 'nscd',
        pin      => $nscd_pkg_version,
        priority => 1001,
    }
    apt::pin { 'toolforge-libnss-db-pinning':
        package  => 'libnss-db',
        pin      => $libnss_db_pkg_version,
        priority => 1001,
    }
    apt::pin { 'toolforge-python-ldap-pinning':
        package  => 'python-ldap',
        pin      => $python_ldap_pkg_version,
        priority => 1001,
    }
    apt::pin { 'toolforge-ldap-utils-pinning':
        package  => 'ldap-utils libldap*',
        pin      => $ldap_utils_pkg_version,
        priority => 1001,
    }
    apt::pin { 'toolforge-libnss3-pinning':
        package  => 'libnss3**',
        pin      => $libnss3_pkg_version,
        priority => 1001,
    }
    # sssd
    if debian::codename::ge('buster') {
        apt::pin { 'toolforge-sssd-pinning':
            package  => 'sssd*',
            pin      => $sssd_pkg_version,
            priority => 1001,
        }
    }

    apt::pin { 'toolforge-nfs-common-pinning':
        package  => 'nfs-common',
        pin      => $nfs_common_pkg_version,
        priority => 1001,
    }
    apt::pin { 'toolforge-libnfsidmap2-pinning':
        package  => 'libnfsidmap2',
        pin      => $libnfsidmap2_pkg_version,
        priority => 1001,
    }
}