|
MediaWiki REL1_35
|
Similar to FauxRequest, but only fakes URL parameters and method (POST or GET) and use the base request for the remaining stuff (cookies, session and headers). More...


Public Member Functions | |
| __construct (WebRequest $base, $data, $wasPosted=false) | |
| Stable to call. | |
| getAcceptLang () | |
| Parse the Accept-Language header sent by the client into an array. | |
| getAllHeaders () | |
| Get an array containing all request headers. | |
| getCookie ( $key, $prefix=null, $default=null) | |
| Get a cookie from the $_COOKIE jar. | |
| getElapsedTime () | |
| Get the number of seconds to have elapsed since request start, in fractional seconds, with microsecond resolution. | |
| getHeader ( $name, $flags=0) | |
| Get a request header, or false if it isn't set. | |
| getIP () | |
| Work out the IP address based on various globals For trusted proxies, use the XFF client IP (first of the chain) | |
| getProtocol () | |
| Get the current URL protocol (http or https) | |
| getSession () | |
| Return the session for this request. | |
| getSessionData ( $key) | |
| Get data from the session. | |
| setIP ( $ip) | |
| setSessionData ( $key, $data) | |
| Set session data. | |
Public Member Functions inherited from FauxRequest | |
| __construct ( $data=[], $wasPosted=false, $session=null, $protocol='http') | |
| Stable to call. | |
| getMethod () | |
| Get the HTTP method used for this request. | |
| getQueryValues () | |
| getRawInput () | |
| FauxRequests shouldn't depend on raw request data (but that could be implemented here) | |
| getRawPostString () | |
| FauxRequests shouldn't depend on raw request data (but that could be implemented here) | |
| getRawQueryString () | |
| FauxRequests shouldn't depend on raw request data (but that could be implemented here) | |
| getRequestURL () | |
| getSessionArray () | |
| getText ( $name, $default='') | |
| setCookie ( $key, $value, $prefix=null) | |
| setCookies ( $cookies, $prefix=null) | |
| setHeader ( $name, $val) | |
| setHeaders ( $headers) | |
| setRequestURL ( $url) | |
| wasPosted () | |
Public Member Functions inherited from WebRequest | |
| __construct () | |
| appendQueryArray ( $array) | |
| Appends or replaces value of query variables. | |
| appendQueryValue ( $key, $value) | |
| checkUrlExtension ( $extWhitelist=[]) | |
| This function formerly did a security check to prevent an XSS vulnerability in IE6, as documented in T30235. | |
| getArray ( $name, $default=null) | |
| Fetch an array from the input or return $default if it's not set. | |
| getBool ( $name, $default=false) | |
| Fetch a boolean value from the input or return $default if not set. | |
| getCheck ( $name) | |
| Return true if the named value is set in the input, whatever that value is (even "0"). | |
| getCrossSiteCookie ( $key, $prefix='', $default=null) | |
| Get a cookie set with SameSite=None possibly with a legacy fallback cookie. | |
| getFileName ( $key) | |
| Return the original filename of the uploaded file, as reported by the submitting user agent. | |
| getFileTempname ( $key) | |
| Return the path to the temporary file where PHP has stored the upload. | |
| getFloat ( $name, $default=0.0) | |
| Fetch a floating point value from the input or return $default if not set. | |
| getFullRequestURL () | |
| Return the request URI with the canonical service and hostname, path, and query string. | |
| getFuzzyBool ( $name, $default=false) | |
| Fetch a boolean value from the input or return $default if not set. | |
| getInt ( $name, $default=0) | |
| Fetch an integer value from the input or return $default if not set. | |
| getIntArray ( $name, $default=null) | |
| Fetch an array of integers, or return $default if it's not set. | |
| getIntOrNull ( $name) | |
| Fetch an integer value from the input or return null if empty. | |
| getLimitOffset ( $deflimit=50, $optionname='rclimit') | |
| Same as ::getLimitOffsetForUser, but without a user parameter, instead using $wgUser. | |
| getLimitOffsetForUser (User $user, $deflimit=50, $optionname='rclimit') | |
| Check for limit and offset parameters on the input, and return sensible defaults if not given. | |
| getPostValues () | |
| Get the values passed via POST. | |
| getQueryValuesOnly () | |
| Get the values passed in the query string only, not including the path router parameters. | |
| getRawVal ( $name, $default=null) | |
| Fetch a scalar from the input without normalization, or return $default if it's not set. | |
| getSessionId () | |
| Get the session id for this request, if any. | |
| getUpload ( $key) | |
| Return a WebRequestUpload object corresponding to the key. | |
| getUploadError ( $key) | |
| Return the upload error or 0. | |
| getVal ( $name, $default=null) | |
| Fetch a scalar from the input or return $default if it's not set. | |
| getValueNames ( $exclude=[]) | |
| Returns the names of all input values excluding those in $exclude. | |
| getValues () | |
| Extracts the given named values into an array. | |
| hasSafeMethod () | |
| Check if this request uses a "safe" HTTP method. | |
| interpolateTitle () | |
| Check for title, action, and/or variant data in the URL and interpolate it into the GET variables. | |
| isSafeRequest () | |
| Whether this request should be identified as being "safe". | |
| markAsSafeRequest () | |
| Mark this request as identified as being nullipotent even if it is a POST request. | |
| normalizeUnicode ( $data) | |
| Recursively normalizes UTF-8 strings in the given array. | |
| response () | |
| Return a handle to WebResponse style object, for setting cookies, headers and other stuff, for Request being worked on. | |
| setSessionId (SessionId $sessionId) | |
| Set the session for this request. | |
| setVal ( $key, $value) | |
| Set an arbitrary value into our get/post data. | |
| unsetVal ( $key) | |
| Unset an arbitrary value from our get/post data. | |
Private Attributes | |
| $base | |
| $ip | |
Additional Inherited Members | |
Static Public Member Functions inherited from WebRequest | |
| static | detectProtocol () |
| Detect the protocol from $_SERVER. | |
| static | detectServer () |
| Work out an appropriate URL prefix containing scheme and host, based on information detected from $_SERVER. | |
| static | extractTitle ( $path, $bases, $key=false) |
| URL rewriting function; tries to extract page title and, optionally, one other fixed parameter value from a URL path. | |
| static | getGlobalRequestURL () |
| Return the path and query string portion of the main request URI. | |
| static | getPathInfo ( $want='all') |
| Extract relevant query arguments from the http request uri's path to be merged with the normal php provided query arguments. | |
| static | getRequestId () |
| Get the unique request ID. | |
| static | getRequestPathSuffix ( $basePath) |
| If the request URL matches a given base path, extract the path part of the request URL after that base, and decode escape sequences in it. | |
| static | overrideRequestId ( $id) |
| Override the unique request ID. | |
Public Attributes inherited from WebRequest | |
| const | GETHEADER_LIST = 1 |
| Flag to make WebRequest::getHeader return an array of values. | |
Protected Member Functions inherited from FauxRequest | |
| getRawIP () | |
| initHeaders () | |
| Initialise the header list. | |
Protected Attributes inherited from FauxRequest | |
| $cookies = [] | |
Protected Attributes inherited from WebRequest | |
| array | $data |
| The parameters from $_GET, $_POST and the path router. | |
| array | $headers = [] |
| Lazy-initialized request headers indexed by upper-case header name. | |
| bool | $markedAsSafe = false |
| Whether this HTTP request is "safe" (even if it is an HTTP post) | |
| string | $protocol |
| Cached URL protocol. | |
| array | $queryAndPathParams |
| The parameters from $_GET. | |
| $queryParams | |
| The parameters from $_GET only. | |
| float | $requestTime |
| The timestamp of the start of the request, with microsecond precision. | |
| SessionId null | $sessionId = null |
| Session ID to use for this request. | |
Similar to FauxRequest, but only fakes URL parameters and method (POST or GET) and use the base request for the remaining stuff (cookies, session and headers).
@newable
Definition at line 36 of file DerivativeRequest.php.
| DerivativeRequest::__construct | ( | WebRequest | $base, |
| $data, | |||
$wasPosted = false |
|||
| ) |
Stable to call.
| WebRequest | $base | |
| array | $data | Array of non-urlencoded key => value pairs, the fake GET/POST values |
| bool | $wasPosted | Whether to treat the data as POST |
Definition at line 48 of file DerivativeRequest.php.
References $base, WebRequest\$data, and FauxRequest\$wasPosted.
| DerivativeRequest::getAcceptLang | ( | ) |
Parse the Accept-Language header sent by the client into an array.
This logic is aligned with RFC 7231 section 5 (previously RFC 2616 section 14), at https://tools.ietf.org/html/rfc7231#section-5.3.5.
Earlier languages in the list are preferred as per the RFC 23282 extension to HTTP/1.1, at https://tools.ietf.org/html/rfc3282.
Reimplemented from WebRequest.
Definition at line 77 of file DerivativeRequest.php.
| DerivativeRequest::getAllHeaders | ( | ) |
Get an array containing all request headers.
Reimplemented from WebRequest.
Definition at line 61 of file DerivativeRequest.php.
| DerivativeRequest::getCookie | ( | $key, | |
$prefix = null, |
|||
$default = null |
|||
| ) |
Get a cookie from the $_COOKIE jar.
| string | $key | The name of the cookie |
| string | null | $prefix | A prefix to use for the cookie name, if not $wgCookiePrefix |
| mixed | null | $default | What to return if the value isn't found |
Reimplemented from FauxRequest.
Definition at line 53 of file DerivativeRequest.php.
| DerivativeRequest::getElapsedTime | ( | ) |
Get the number of seconds to have elapsed since request start, in fractional seconds, with microsecond resolution.
Reimplemented from WebRequest.
Definition at line 93 of file DerivativeRequest.php.
| DerivativeRequest::getHeader | ( | $name, | |
$flags = 0 |
|||
| ) |
Get a request header, or false if it isn't set.
| string | $name | Case-insensitive header name |
| int | $flags | Bitwise combination of: WebRequest::GETHEADER_LIST Treat the header as a comma-separated list of values, as described in RFC 2616 ยง 4.2. (since 1.26). |
Reimplemented from WebRequest.
Definition at line 57 of file DerivativeRequest.php.
| DerivativeRequest::getIP | ( | ) |
Work out the IP address based on various globals For trusted proxies, use the XFF client IP (first of the chain)
| MWException |
Reimplemented from WebRequest.
Definition at line 81 of file DerivativeRequest.php.
| DerivativeRequest::getProtocol | ( | ) |
Get the current URL protocol (http or https)
Reimplemented from FauxRequest.
Definition at line 89 of file DerivativeRequest.php.
| DerivativeRequest::getSession | ( | ) |
Return the session for this request.
This might unpersist an existing session if it was invalid.
Reimplemented from WebRequest.
Definition at line 65 of file DerivativeRequest.php.
| DerivativeRequest::getSessionData | ( | $key | ) |
Get data from the session.
| string | $key | Name of key in the session |
Reimplemented from WebRequest.
Definition at line 69 of file DerivativeRequest.php.
| DerivativeRequest::setIP | ( | $ip | ) |
| string | $ip |
Reimplemented from WebRequest.
Definition at line 85 of file DerivativeRequest.php.
References $ip.
| DerivativeRequest::setSessionData | ( | $key, | |
| $data | |||
| ) |
Set session data.
| string | $key | Name of key in the session |
| mixed | $data |
Reimplemented from WebRequest.
Definition at line 73 of file DerivativeRequest.php.
References WebRequest\$data.
|
private |
Definition at line 37 of file DerivativeRequest.php.
Referenced by __construct().
|
private |
Definition at line 38 of file DerivativeRequest.php.
Referenced by setIP().